Why is my Virtual Machine loading so slow in VMware Fusion?

At work, I am assigned a MacBook Air to use it primarily and since it is running Mac OS, there will be times when I definitely will require a Windows image to do whatever I can’t do on a Mac. So there was this Windows 7 Enterprise virtual machine image that was provided by the IT team and have it loaded into VMware Fusion for use. There was this unbearable pain initially when using the image as it is simply crawling for me! When I meant, “Crawling” is that, each operation you made will take between 10-30 seconds to complete and sometimes it will hung there all the while!

I meddled around with the settings such as adjusting the amount of processor or memory that is allocated but to no avail. I was constantly monitoring the utilization on my Mac to make sure that I am not over-allocating too much to the Virtual Machine (VM).

I found this setting that once I toggle with it, the Virtual Machine went on speeding like crazily fast! (OK, just a little exaggerating here as it really makes a lot of difference!

Notice the portion that says “Hard disk buffering”. It is now set as “Disabled” as it works for me. Look at the other options that was available.

So initially when the Virtual Machine is being configured, it was set to “Automatic” and thus the crawling of the whole VM which totally made the performance degraded.

There are a lot of articles online that tells you that you should disable this if you encounter performance degradation.

Cheers.

Milton Goh

Why is my Virtual Machine loading so slow in VMware Fusion?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s